Lab. voice via wireless

Posted on Posted in Cyber, Networking

Lab. voice via wireless

Assalamu’alaikum Warahmatullahi Wabarakatu

Semangat lagi kawan, saat ini kita akan mengoprek IP Phone ( cisco ) lagi, kita bisa kembangkan lagi voice ini bisa melawati media transmisi nirkabel, supaya ga habisin pulsa ( hehehe 😂😂), dan supaya pengguna smartphone saat ini dapat calling satu dengan yang lain tanpa pulsa 😁😁😁. tapi untuk smartphone supaya terhubung ke jaringan voice wajib terpasang Aplikasi SCCP Phone bisa download di playstore ( toko buka ), dan PC atau Laptop juga ada wajib Aplikasi yang harus dipasang aplikasi voice ,, jika mau belajar Basic VoIP Klik disini

kayaknya pada ga sabar ngoprek nih, kita langsung ke TKP…

kita bisa lihat gambar topologi dibawah ini : ↴

  1. Tahapan lab :
  • Setting IP Address router
  • Setting IP DHCP Pool ( voice , data , AP )
  • Setting telephony service pada router
  • Setting Vlan Voice 10, Vlan data 20, Vlan AP 30 di switch
  •   Setting Dial number di Router
  • Menyalakan IP Phone
  • Melakukan panggilan
  1. Verfikasi lab
  • pastikan antar IP Phone bisa saling tesTerhubung
  • PC, HP, TABLET, LAPTOP wajib saling terhubung ( telpon-telponan )
  1. Konfigurasi Lab :

4.1. Konfigurasi di  ROUTER :

  • Konfigurasi IP Address

Klik pada router, pilih Tab CLI kemudian ketikan perintah berikut :

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#no sh

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#int f0/0.10

Router(config-subif)#

%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip add 192.168.10.1 255.255.255.248

Router(config-subif)#exit

Router(config)#int f0/0.20

Router(config-subif)#

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip add 192.168.20.1 255.255.255.248

Router(config-subif)#int f0/0.30

Router(config-subif)#

%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

Router(config-subif)#encapsulation dot1Q 30

Router(config-subif)#ip add 192.168.30.1 255.255.255.248

Router(config-subif)#exit

Router(config)#

  • Konfigurasi DHCP

Router(config)#ip dhcp pool data

Router(dhcp-config)#default-router 192.168.20.1

Router(dhcp-config)#network 192.168.20.0 255.255.255.248

Router(dhcp-config)#exit

Router(config)#ip dhcp pool voice

Router(dhcp-config)#default-router 192.168.10.1

Router(dhcp-config)#network 192.168.10.0 255.255.255.248

Router(dhcp-config)#option 150 ip 192.168.10.1

Router(dhcp-config)#exit

Router(config)#ip dhcp pool AP

Router(dhcp-config)#default-router 192.168.30.1

Router(dhcp-config)#network 192.168.30.0 255.255.255.248

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 192.168.10.1

Router(config)#ip dhcp excluded-address 192.168.20.1

Router(config)#ip dhcp excluded-address 192.168.30.1

Router(config)#

  • Konfigurasi SCCP

Router(config)#telephony-service

Router(config-telephony)#max-dn 10

Router(config-telephony)#max-ephone 10

Router(config-telephony)#auto assign 1 to 10

Router(config-telephony)#ip source-address 192.168.10.1 port 2000

Router(config-telephony)#exit

  • Konfigurasi jumlah ephone yang akan digunakan

Router(config)#ephone 1

Router(config-ephone)#ephone 2

Router(config-ephone)#ephone 3

Router(config-ephone)#ephone 4

Router(config-ephone)#ephone 5

Router(config-ephone)#ephone 6

Router(config-ephone)#ephone 7

Router(config-ephone)#ephone 8

Router(config-ephone)#ephone 9

Router(config-ephone)#ephone 10

Router(config-ephone)#exit

  • Konfigurasi ephone-dn

Router(config)#ephone-dn 1

%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state to up

Router(config-ephone-dn)#number 111

Router(config-ephone-dn)#ephone-dn 2

%IPPHONE-6-REGISTER: ephone-2 IP:192.168.20.3 Socket:2 DeviceType:Phone has registered.

%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state to up

Router(config-ephone-dn)#number 112

Router(config-ephone-dn)#ephone-dn 3

%LINK-3-UPDOWN: Interface ephone_dsp DN 3.1, changed state to up

Router(config-ephone-dn)#number 113

Router(config-ephone-dn)#ephone-dn 4

%IPPHONE-6-REGISTER: ephone-5 IP:192.168.10.2 Socket:2 DeviceType:Phone has registered.

%LINK-3-UPDOWN: Interface ephone_dsp DN 4.1, changed state to up

Router(config-ephone-dn)#number 114

%IPPHONE-6-REGISTER: ephone-3 IP:192.168.10.3 Socket:2 DeviceType:Phone has registered.

%IPPHONE-6-REGISTER: ephone-4 IP:192.168.30.4 Socket:2 DeviceType:Phone has registered.

%LINK-3-UPDOWN: Interface ephone_dsp DN 5.1, changed state to up

Router(config-ephone-dn)#ephone-dn 5

Router(config-ephone-dn)#number 115

Router(config-ephone-dn)#ephone-dn 6

%LINK-3-UPDOWN: Interface ephone_dsp DN 6.1, changed state to up

%IPPHONE-6-REGISTER: ephone-1 IP:192.168.20.2 Socket:2 DeviceType:Phone has registered.

ephone-dn 6

Router(config-ephone-dn)#number 116

Router(config-ephone-dn)#ephone-dn 7

%LINK-3-UPDOWN: Interface ephone_dsp DN 7.1, changed state to up

Router(config-ephone-dn)#number 117

Router(config-ephone-dn)#ephone-dn 8

%LINK-3-UPDOWN: Interface ephone_dsp DN 8.1, changed state to up

Router(config-ephone-dn)#number 118

Router(config-ephone-dn)#ephone-dn 9

%LINK-3-UPDOWN: Interface ephone_dsp DN 9.1, changed state to up

Router(config-ephone-dn)#number 119

Router(config-ephone-dn)#ephone-dn 10

%LINK-3-UPDOWN: Interface ephone_dsp DN 10.1, changed state to up

Router(config-ephone-dn)#number 120

Router(config-ephone-dn)#exit

Router(config)#

4.2. Konfigurasi di swicth

Switch>en

Switch#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#int f0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#int f0/2

Switch(config-if)#switchport access vlan 30

Switch(config-if)#int ra f0/3-4

%SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 30 on FastEthernet0/3 VLAN1.

%SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/3 on VLAN0001. Inconsistent local vlan.

Switch(config-if-range)#switchport access vlan 20

Switch(config-if-range)#switchport voice vlan 10

Setelah selesai step yang kita lakukan, sekarang saya akan mecontohkan cara mengisikan IP TFTP, Kalian bisa lihat gambar dibawah ini : 👇

  1. pastikan device nirkabel ( HP, Tablet, Laptop ) sudah terhubung ke jaringan Voice alias sudah konek ke AP sebagai jalur penyiar gelombang radio, dan sudah mendapatkan IP DHCP client.

  1. Setelah mendapatkan IP DHCP, Kemudian kita setting IP TFTP di Aplikasi IP COMMUNICATOR .

klik option di pojok kiri atas -> lalu pilih Preferences , pada kolom TFTP SERVER pilih Use these TFTP Servers , kemudian masukan ip gw vlan 30 di Kolom TFTP Server 1:

Setelah terisi, secara otomatis si Aplikasi IP Communicator dapat no. Dial-UP

lakukan perintah diatas ke semua HOST yang terhubung ke AP maupun terhubung IP phone.

Setelah Langkah semua telah dilakukan kita coba tes call dari Smartphone ke PC 1 atau IPPHONE

( Smartphone ke IPPHONE 1 )

( Smartphone ke PC 1 )

jika ada yang bingung bisa kunjungi channel youtube saya :

PART. 1 Lab. VoIP via Wireless

PART.2 Lab. VoIP via Wireless

Alhamdulillah Lab kita telah berhasil,,,

Salam

Hamdan H.

Leave a Reply

Your email address will not be published. Required fields are marked *